yum 安装报错 File "/usr/bin/yum", line 30 except KeyboardInterrupt, e:

2021-03-18 20:09 来源:未知 作者:mas 责编:mas

yum 安装报错 File "/usr/bin/yum", line 30 except KeyboardInterrupt, e:

描述:

  将centos7升的python版本由2.7升级到3.9之后,发现yum命令报错,错误如下:  

File "/usr/bin/yum", line 30
    except KeyboardInterrupt, e:
                            ^
SyntaxError: invalid syntax

问题原因:

  yum是使用python2*等开发,在升级到python3之后语法报错

解决方案:

  修改 /usr/bin/yum和/usr/libexec/urlgrabber-ext-down文件,指定使用python2.7作为yum的解释器。

  具体如下:

vim /usr/bin/yum

#!/usr/bin/python2.7
import sys
try:
    import yum
except ImportError:
    print >> sys.stderr, """\

vim /usr/libexec/urlgrabber-ext-down
 
#! /usr/bin/python2.7
#  A very simple external downloader
#  Copyright 2011-2012 Zdenek Pavlas
 
#   This library is free software; you can redistribute it and/or
#   modify it under the terms of the GNU Lesser General Public

 

【版权声明】本站部分内容来源于互联网,本站不拥有所有权,如果发现本站有侵权的内容,欢迎发送邮件至 benumon@163.com 举报,并提供相关证据,一经查实,本站将立刻删除涉嫌侵权内容。

分享:

更多文章

相关文章

关键词:

一生受益-思韵闪耀-专业IT技术社区 - 爱编程,爱源码,爱技术,一生受益。

powerby 一生受益-思韵闪耀    豫ICP备13002912号-2